Troubleshoot: FileVault Sync Issue on Mac After Federated Password Change

Symptom

FileVault encryption is enabled, but the sync process fails for users with federated accounts. It requires two different passwords to login:

  • Old password for FileVault login window
  • New password at macOS Login window

Cause

This happens when the local account password is changed via the Forgot Password? option after Google Workspace (GWS) authentication.

If a Password reset is done after the Filevault is enabled, the new password will not sync with the FileVault. Instead Filevault will continue to use the Old password to grant you access followed by a macOS login page where the new password is required to enter.

Resolution

After a password change, lock and unlock your Mac with the new password right away to synchronize it with FileVault. Restart the device and type your new password in the FileVault window to log in, to Verify if the password sync was successful.

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