Symptom
When the admin attempts to start a Remote Assist session, the connection fails due to a communication issue with the end user device.
Causes
Remote Assist relies on the AWS IoT service that uses MQTT (Message Queuing Telemetry Transport) for sending real-time updates to end user devices. See Amazon’s official documentation for How AWS IoT works to learn more.
When initiating a Remote Assist session, the remote-assist service generates a connection start message. If the connection between the AWS IoT service and the end-user device is lost, or if the AWS IoT service experiences downtime, the message will fail to reach the device, which prevents the Remote Assist session from starting.
Here are some reasons why the connection to AWS IoT service might fail:
- AWS IoT service URL not whitelisted: A firewall might be blocking the connection initiation requests to the AWS IoT service domain
a1hrq03pdcca60-ats.iot.us-east-1.amazonaws.com:443
. - Timeout: The AWS IoT service may not have responded to the system in time, causing the system’s timeout to exceed.
- Certificates: There could be an issue with the certificates used for communication with the AWS IoT service. Incorrect system date time may cause Certificate validation errors.
Resolution
To ensure that the AWS IoT service connection is working correctly for the Remote Assist session to be initiated, you can run a series of JumpCloud commands.
Note:
- Ensure the targeted device is online to successfully run the commands.
- Ensure communication to
a1hrq03pdcca60-ats.iot.us-east-1.amazonaws.com:443
is allowed by your firewalls. See Understanding the Remote Assist Agent to learn more.
To run commands, follow these steps:
- Log in to the JumpCloud Admin Portal.
- Go to DEVICE MANAGEMENT > Commands.
- Click the + icon, then click Command From Template. See Creating a Command from a template to learn more.
- Click Windows, Mac OS, or Linux to select the device type.
- In the Search bar, type MQTT Troubleshooting Script to find the template.
- Click configure to view the template details.
- Click the Devices tab, and select the devices on which to run the command.
- Click save. The Commands page displays the newly created command.
- On the newly created command, click Run Now to run the script on your selected devices. This may take a few seconds to complete.
- After the command is finished running, click the Results tab and then click view to review the command result details.