Troubleshoot: Windows Connect Key

This article addresses an issue where you are unable to add a Windows device to JumpCloud with a valid Connect Key.

Symptoms

When installing the JumpCloud Agent on a Windows device using a valid admin account and Connect Key, installation fails or the device does not register.

Possible Causes

Before performing any steps to resolve the issue, check the following:

  • Key Type: Confirm you are using the Connect Key and not the API key. See Understanding the Connect Key.
  • Organization: Confirm you are authenticated to the correct org and are using the correct Connect Key for that org. This can be an issue if you have access to multiple JumpCloud orgs.
  • Active Directory Binding: Confirm the device is not bound to Active Directory. To check this on a Windows device:
    1. Click Start and enter system to search for Advanced System Settings.
    2. Open Advanced System Settings and click the Computer Name tab.
    3. A domain joined device will list the domain under the Full computer name.
  • Install Log: Check the JumpCloud install log in C:\Users\(accountusedtoinstall)\AppData\Local\Temp\jcagent.log.

Important:

AppData is a hidden system file.

  • Verify if the following line exists in the install log:
    error='Could not unmarshal bootstrap file 'C:\Program Files\JumpCloud\Plugins\Contrib\agentBootstrap.json', err='invalid character '\n' in string literal'

Important:

This error indicates an extraneous hard return (newline character) is present in the Connect Key string. This is often a hidden character introduced when copying the key from certain text editors on Windows. When working with the Connect Key, it is best to copy from the Admin Portal, a terminal, or to manually enter in the value.

Resolution

If you see the previous error in the agent’s install.log, follow these steps:

  1. Copy the Connect Key to Notepad.
  2. Verify there are no hard returns or spaces within the key.
  3. Copy and paste the key into the installer prompt.
  4. If the installation continues to fail, manually enter the Connect Key in the Agent Installer Wizard.
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