Symptoms
When an Admin is setting up JumpCloud Password Manager for a new tenant, they may encounter the following error message in Settings.
Cause
This may be caused by a database error.
Resolution
This can be resolved by completely deactivating and re-activating the password manager for the tenant. To fix this, follow these steps:
- Delete the cloud backup key using the following API:
curl --request DELETE \
--url https://console.jumpcloud.com/api/v2/passwordmanager/backup/keys/{UUID} \
--header 'x-api-key: REPLACE_KEY_VALUE' - Replace the values in the above API and run it. To fetch the UUID, run the following API:
curl --request GET \
--url 'https://console.jumpcloud.com/api/v2/passwordmanager/backup/keys' \
--header 'x-api-key: REPLACE_KEY_VALUE' - After you delete the cloud backup key, deactivate the Password Manager completely using the following API:
curl --request DELETE \
--url https://console.jumpcloud.com/api/v2/passwordmanager \
--header 'x-api-key: REPLACE_KEY_VALUE' - After the password manager is deactivated, refresh the admin console and try to set it up again for your account.
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