Troubleshoot: Error While Loading Password Manager Settings in Admin Console

Symptoms

When an Admin is setting up JumpCloud Password Manager for a new tenant, they may encounter the following error message in Settings.

A page showing Settings in JumpCloud admin console.

Cause

This may be caused by a database error. 

Resolution

This can be resolved by completely deactivating and re-activating the password manager for the tenant. To fix this, follow these steps:

  1. Delete the cloud backup key using the following API:
    curl --request DELETE \
    --url https://console.jumpcloud.com/api/v2/passwordmanager/backup/keys/{UUID} \
    --header 'x-api-key: REPLACE_KEY_VALUE'
  2. Replace the values in the above API and run it. To fetch the UUID, run the following API:
    curl --request GET \
    --url 'https://console.jumpcloud.com/api/v2/passwordmanager/backup/keys' \
    --header 'x-api-key: REPLACE_KEY_VALUE'
  3. After you delete the cloud backup key, deactivate the Password Manager completely using the following API:
    curl --request DELETE \
    --url https://console.jumpcloud.com/api/v2/passwordmanager \
    --header 'x-api-key: REPLACE_KEY_VALUE'
  4. After the password manager is deactivated, refresh the admin console and try to set it up again for your account.
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