Troubleshoot: JumpCloud Login Options Missing on Windows

The JumpCloud agent requires specific dependencies for JumpCloud-specific features to function. The agent attempts to install these dependencies automatically, but if this process fails, the device may revert to default Windows login behavior. This prevents JumpCloud-specific features from working. 

Symptoms

Users may experience the following symptoms on an affected Windows device:

  • The user is not prompted for MFA on device log in, even if it is enforced for both the user and the device by the admin.
  • Users attempting to reset their password via CTRL+ALT+DEL may receive an error or cause the device password to fall out of sync with JumpCloud.
  • The Sign-in with JumpCloud option does not appear on the device login window, even when the Self-Service Account Provisioning (SSAP) feature is enabled. 

Cause

If any one of the dependencies fails to install automatically, the device reverts back to Windows default login behavior, which does not support specific JumpCloud functionality.

To check for the presence of dependencies:

  1. On a Windows device, go to Start > Settings.
  2. Go to Apps > Apps & Features or Installed Apps.
  3. In the App list, search for the following:
    • Microsoft Visual C++ 2022 Redistributable 
    • Microsoft ASP.NET Core 8.0.x
    • Windows Desktop Runtime - 8.0.x

Resolution

To resolve the issue, you must install the following dependencies manually on the affected device(s). Download and run the installers depending on the device’s hardware architecture:

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